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Operating instructions

1 Operating instructions
You will find further information in the operating instructions for the safety laser scanner:

• S3000

• S300

• S200
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Selection of the laser scanner
variants

2 Selection of the laser scanner variants
In the device selection wizard you can select the variants of the S3000 and S300 safety
laser scanner (see also the basic description “Working with projects” in the CDS manual or
in the CDS help).

S3000

Several sensor heads and I/O modules are available for the S3000 (see also the S3000
operating instructions).

The sensor heads differ in their maximum scanning range and the resulting possible size
of the protective field.

The I/O modules define the range of functions in the S3000 and have different inputs.

� If you selected the device class S3000 in the previous dialog box, now choose the
sensor head and the I/O module for the S3000 in the device selection wizard.

S300

Various S300 variants are available (see also the operating instructions for the S300) to
cover the different applications.

� If you selected the device class S300 in the previous dialog box, now choose the S300
variant in the device selection wizard.

S200

There is only device variant available.

� If in the previous dialog box you selected the device class S200, in the device selection
wizard click the Finish button.
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Configuration of the laser
scanner

3 Configuration of the laser scanner
Please read the basic description of the configuration using the CDS.

On a system that comprises two safety laser scanners, both scanners are configured in
one configuration window. The configuration comprises:

• the configuration of the scanner system
(e.g. the resolution, the restart behaviour and the monitoring cases)

• the configuration of the two safety laser scanners
(e.g. the protective fields and warning fields)

WARNING

Check the configuration for each monitoring case and after every change!

Once you have successfully transferred the configuration, a machine or plant protected by
the safety laser scanner must be checked and released by specialist personnel. If you
configure several monitoring cases (see 3.8 “Monitoring cases” on page 14), then you
must test the protective device for effectiveness for each of these monitoring cases
individually.

3.1 Application name
Enter a name for your application. The name is saved in the devices after the configuration
has been transferred. The name chosen may be, for example, the identifier for the vehicle,
system or the machine. You can enter a name with a maximum of 16 characters.

If you assign unique application names, you may “reserve” the devices for certain duties. A
machine maintenance person comparing exchanged devices with the configuration data
saved in the CDS will be notified that the application name does not match. He may then
exchange these devices for those with the correct application name.

3.1.1 Name of the scanner

Enter a name for each of the scanners in the system.

Use meaningful names, e.g. “front” and “rear” for vehicle monitoring. Unique device
names make the subsequent configuration steps easier (for example on allocating the
control inputs or the OSSDs).

On a master/slave system with two scanners, the device names must always be different.
You can enter names with a maximum of 16 characters.

3.1.2 User data

You can enter your name in the field Name of the user. This is then added to the
configuration protocol and in the diagnostics report.

3.2 Application
In principle you can choose between stationary or mobile applications for a safety laser
scanner.

• Select Stationary if the scanner is operated stationary on a machine or plant.

• Select Mobile if the scanner is operated mobile on a vehicle (e.g. AGV).

The configuration features subsequently available in the CDS depend on the selection
made.

Note

Recommendation
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3.2.1 Resolution

Select the necessary resolution in millimetres for your application. The maximum
protective field range depends on the resolution selected, this range is indicated in
Maximum protective field range (see also the operating instructions of the related safety
laser scanner).

The protective field range must be adequate …

• in case of horizontal mounting, to ensure the necessary safety distance including the
safety supplements is provided.

• to protect the entire access or hazardous area on vertical mounting.

The protective field range defines the maximum size of the protective field that you can
edit in the field set editor.

In certain circumstances you may need to adapt existing protective fields after changing
the resolution in the field set editor. This is the case if you have already drawn protective
fields in the field editor (e.g. for an old application) and these protective fields are larger
than the maximum protective field range for the resolution selected.

WARNING

In horizontal applications in which you use 70 mm resolution, ensure that a human leg
can be detected!

Mount the scan planes …

• for stationary applications with 70 mm resolution at least 300 mm above the floor! In
case of scan planes higher than 300 mm, ensure that people cannot reach the
hazardous area by crawling underneath the scan plane!

• for mobile applications at a maximum height of 200 mm!

3.2.2 Basic response time

The basic response time of the safety laser scanner is displayed in this field.

• On the S300 and S200 this is the fixed basic response time of the related device.

• On the S3000 you can choose between two protective field ranges. The basic response
time of the scanner is also dependent on the selection. For the shorter protective field
range offered, the scanner has a shorter basic response time than for the larger
protective field range (see also the S3000 operating instructions).

WARNING

Use the total response time of the system to calculate the safety distance (see also the
operating instructions of the related safety laser scanner, chapter “Mounting”)!

The total response time depends on …

• the basic response time.

• the multiple sampling set.

• the transmission speed of input signals via EFI.

• the transmission speed of the OSSD signals via EFI.

3.2.3 Maximum protective field range of the S3000

The maximum protective field range of the S3000 is primarily dependent on the resolution
you have selected. You can then choose between two protective field ranges. However,
this selection does not affect the basic response time of the scanner.

Note
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3.3 Control inputs
The Advanced and Professional variants of the safety laser scanner have control inputs
with which it is possible to switch between monitoring cases.

• The Advanced variants have static control inputs, e.g. for tactile sensors.

• The Professional variants have static and dynamic control inputs, e.g. for incremental
encoders on an AGV.

Always use the inputs on the master to switch between the monitoring cases in a
master/slave system.

3.3.1 Control inputs for mobile applications

If you activate the Use dynamic control inputs option with a Professional or Expert safety
laser scanner, then you can set the parameters for control inputs for incremental
encoders.

In addition, two of the existing inputs are used in Control inputs used (A and B on the
S300 or C and D on the S3000).

The option Use dynamic control inputs is only available if you have selected the Mobile
option (during the definition of the application).

3.3.2 Control inputs used

In Control inputs used you must select the inputs you want to use for the static switching
between the monitoring cases.

The control inputs available depend on the safety laser scanner variant and also on
whether inputs are already used as dynamic control inputs.

Input C on the S300 Professional, Professional CMS or Expert

On the S300 Professional, Professional CMS and Expert you can also select the Use
RESET and RES_REQ as Input C check box. The control input C is then formed from the
RESET and RES_REQ connections.

If you configure the RESET and RES_REQ inputs as control inputs C1/C2, the “With restart
interlock” function is no longer available.

Using the control input C, it is then possible to switch to a monitoring case that makes
possible, for instance, turning on the spot. Complementary sampling is used for the input
and the input overwrites the incremental encoder inputs.

3.3.3 Control inputs for master/slave operation

WARNING

On the use of external control inputs, add 40 ms to the basic response time of the
safety laser scanner!

The total response time of the safety laser scanner increases due to the transmission via
EFI.

In a master/slave system the control signals for monitoring case switching must be on the
inputs on the master. The slave is connected to the master via EFI and receives from the
master the input information for monitoring case switching.

In the Use from field choose the device that is to act as the master and on which the
control inputs are to be used.

On a system that comprises an S3000 and an S300, the S3000 always has the function
of the master. For this reason its control inputs must be used.

Note

Note

Note

Note
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3.3.4 Sampling for the static control inputs

If you are using static sampling, choose between Complementary or 1-of-nsampling
depending on the control facilities available.

3.3.5 Input delay for static control inputs

The control device that you want to use to switch the control inputs must be able to switch
to the defined input condition within a given time. If this is not the case (e.g. due to bounce
times on the switching contacts connected), in the Input delay [ms] field you can increase
the input delay.

Also pay attention to the notes in the operating instructions of the related safety laser
scanner, section “Time for monitoring case switching”.

3.3.6 Advancement for the switch timing

Under Switching timing advance you can see the time that results from the transfer time
for control signals and OSSD signals over EFI and the input delay.

You must advance the timing of the monitoring case switching for the related scanner by
the corresponding time.

WARNING

Switch to another monitoring case in good time!

The time the scanner needs to switch to a new monitoring case can be longer than its
response time.

If you use external control inputs and/or OSSDs, or if you need an input delay for the
control inputs, you must advance the timing for the switching (see also the operating
instructions of the related safety laser scanner, chapter “Mounting”).

On a master/slave system with two scanners, the times are different for scanner 1 and 2,
as the control signals only need to be transferred for one scanner, but under certain
circumstances the OSSD signals must be transferred over EFI for both scanners. In this
case the CDS displays the times in two fields with the related Scanner names.

Fig. 1: Example for
complementary connection
layout

Fig. 2: Example for 1ofn
connection layout

Note

Note
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3.3.7 Characteristic data for the incremental encoders

To determine the velocity and direction of travel of the vehicle, the Pulses per cm travel as
output by the incremental encoders are required (as a rule you can determine the pulses
per cm travel with the aid of the documentation on the incremental encoder from the
diameter and transmission ratio of the drive gear, or you can determine the pulses per cm
travel by measurement).

In the dialog box below, the minimum and maximum speed calculated from the entries is
displayed.

To safely detect the movement of the vehicle, two independent incremental encoders
must always be connected.

3.3.8 Allowed difference between the incremental encoders

For safety (e.g. on the failure of an encoder) the system compares the two pulse rates
measured with each other. The values output by the incremental encoders are only
allowed to vary by the tolerance entered in the Allowed difference between the encoders
entry field. The maximum setting is 25�%.

The Allowed difference between the encoders is allowed to be exceeded for max.
20 seconds, e.g. for driving around bends (you will find detailed information in the
operating instructions for the related safety laser scanner in the section “Data sheet”). In
this case the larger of the two velocity values is always used for the activation of the
protective field. In this way the highest possible level of safety is ensured.

3.4 Application diagnostic output
The safety laser scanner has an application diagnostic output that can be configured. The
following configuration possibilities are available:

• contamination

• error

• contamination or error

• inactive

On a master/slave system with two safety laser scanners, the outputs for both laser
scanners can be configured independently.

Note

Note

Note
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3.5 OSSDs in master/slave operation
In a master/slave system you define which output signal switching device (OSSD) is
switched to the OFF state on the presence of an object in the protective field.

The name or names for the possible devices are displayed. This can, e.g. be a second
safety laser scanner, a switching amplifier (series UE100) or a bus node (series UE1000).

Select the check box for the device on which the OSSDs are to be switched to the OFF
state if there is an object in the scanner’s protective field.

WARNING

For external OSSDs add 20 ms to the basic response time of the safety laser scanner!

The total response time of the safety laser scanner increases due to the transmission via
EFI.

3.5.1 External device monitoring

After every interruption to the protective field and prior to restarting the machine, the
external device monitoring monitors the switching devices operated by the OSSDs (e.g.
contactors). In this way the external device monitoring detects whether e.g. the (positively
guided) contacts on the contactors connected are in the OFF position. The machine is only
allowed to start if both contactors are in the OFF state, that is they are deactivated.

• If you configure the External device monitoring active function, this device must also
be connected to the EDM input on the safety laser scanner.

• If you do not configure the External device monitoring active function, the contactors
must be monitored by the downstream machine controller and the EDM input must not
be used.

• In master/slave operation you can only activate the external device monitoring on the
safety laser scanner if the internal OSSDs are used.

Notes
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3.6 Restart

WARNING

It is imperative that you configure the safety laser scanner with restart interlock if the
protective field can be left to approach the hazardous point or if a person cannot be
detected at every point in the hazard area for the safety laser scanner!

During the assessment, pay attention to whether the protective field can be left in the
direction of the hazardous point, to areas that are unprotected due to the mounting and
the unprotected near range of the safety laser scanner (see also the operating instructions
of the related safety laser scanner).

You can restart the OSSDs of a safety laser scanner in three ways:

• without restart interlock

Only if an external restart interlock is realised on the machine controller

or

if the protective field cannot be left in the direction of the hazardous point and if people
can be detected by the safety laser scanner at every point in the hazardous area!

The OSSDs are switched to the ON state if there is no object in the active protective field
for the duration given.

• with restart interlock

The OSSDs are only switched to the ON state if the operator operates the control switch
for restart or reset.

If you have configured the RESET and RES_REQ connections as control input C, (see
section 3.3.2 “Control inputs used” on page 9), the “With restart interlock” option can
no longer be configured.

• time delayed

Only if the protective field cannot be left in the direction of the hazardous point and if
people can be detected by the safety laser scanner at every point in the hazardous
area!

The OSSDs are switched to the ON state if there is no object in the active protective field
for the duration given.

3.7 Creating field sets
Add one or more field sets for the safety laser scanner (see also the operating instructions
of the related safety laser scanner). For the created field sets you define later the
protective field and the warning field in the field set editor.

The field sets already defined are displayed in the table in the dialog box. Along with the
name of the field set, the monitoring cases to which the field set is allocated are also
displayed (the monitoring cases are used to switch between the field sets for a safety laser
scanner).

In this dialog box, you can add, edit or delete field sets and change the name of a field set.

Once you have created all field sets available for a safety laser scanner, the Add button is
no longer active.

Note

Note
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Configuration of the laser
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3.7.1 Field set names

Enter a unique name for the field set. With the aid of the name, later you can allocate the
field sets to the monitoring cases and define the protective field and warning field for the
individual field sets. For this reason use meaningful names (e.g. “parking”, “2 m/s” etc.).

You can only use a field set name once.

3.8 Monitoring cases
In operation it is possible to switch between monitoring cases for a safety laser scanner via
static control inputs or using incremental encoders via dynamic control inputs.

The monitoring cases already defined are displayed in the table in the dialog box. You can:

• add monitoring cases

• edit monitoring cases

• delete monitoring cases

It is defined specifically for each monitoring case which field set is to be active with which
multiple sampling.

Using different input conditions (control signals), you can define when, which monitoring
case is to be active.

• You can only add monitoring cases if you have first configured that control inputs on the
safety laser scanner are to be used.

• In a master/slave system, the master defines the number of possible monitoring cases.
If, e.g. an S3000 (master) is connected to an S300 (slave) over EFI, the number of
S3000 monitoring cases is available in the complete system.

• The CDS checks the plausibility of the monitoring cases. Cases for which the input
values overlap or have the same input conditions are not allowed. These cases are
shown in yellow. As long as one or more cases are implausible, you cannot leave the
configuration step Monitoring cases.

In the example shown, the input conditions for the cases Fast forward and Fast
backwards are the same (1).

3.8.1 Monitoring case name

Enter the name for the monitoring case in the field or overwrite the existing name.

A monitoring case name cannot be used more than once. Use a meaningful name that, for
instance, describes the situation in which the monitoring case is applicable (inching
movement, parking, loading, welding, etc.).

Notes

Fig. 3: Implausible
monitoring cases in the table

Note
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3.8.2 Input conditions for static control inputs

With the aid of list boxes you can define which states the static control inputs must take
for the allocated monitoring case to be activated.

• The control inputs for which you can define conditions depend on which control inputs
you have previously configured.

• Whether you can use the Complementary sampling or the 1ofn sampling, depends on
how you have configured the control inputs.

• You are not allowed to configure any input conditions that are already used for another
monitoring case.

If you have selected complementary sampling (see Control inputs):

In the related list boxes choose the logical state that the control input must adopt to
activate the monitoring case:

• If you select 1 or 0, the value selected must be present at the related control input to
meet the input condition.

• If you choose X, the control input is not taken into account for this monitoring case. For
this monitoring case it is then irrelevant as to which input condition is present at this
control input. Only the other control inputs for which you have selected 1 or 0 are
relevant.

Example

A B Monitoring case

1 X 1

0 1 2

0 0 3

1 1 Implausible

1 0 Implausible

In the example the value 1 at control input A is defined for case 1. I.e. as soon as the
value 1 is present at control input A, the device switches to monitoring case 1 irrespective
of which values are present at control input B.

In the example the value 1 for control input A cannot be selected for any other monitoring
case. This would lead to an implausible monitoring case.

If you have selected 1of-n sampling (see Control inputs):

In the related list boxes, select the connection for the control input (A1, A2, B1, B2 etc.) at
which a high signal must be present to activate the monitoring case.

Notes

Fig. 4: Example for
complementary connection
layout

Tab. 1: Example for
complementary sampling

Fig. 5: Example for 1ofn
connection layout
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3.8.3 Input conditions for dynamic control inputs (incremental encoder inputs)

If you use the dynamic incremental inputs for monitoring case switching, you must select
the Use velocity range check box.

� In the from and to fields enter the velocities at which the monitoring case is to be
activated.

The maximum measurable velocities are –2000 cm/s to 2000 cm/s. Values in the
expanded standstill range between –9 cm/s and 9 cm/s cannot be entered. During the
definition of velocity-dependent monitoring cases ensure that the velocity ranges do not
overlap and that there is no undefined range between the velocity ranges.

For defining monitored cases for moving backward, for this reason enter values from
–2000 cm/s to –11 cm/s, for forward movement values from 11 cm/s to 2000 cm/s, for
the standstill range values from –10 cm/s to 10 cm/s. If a monitoring case is to be active
for both backward movement and forward movement, then the expanded standstill range
between –10 cm/s and 10 cm/s must be bridged.

Example

A monitoring case is added for backward movement, forward movement and standstill
range. For the backward movement a monitoring case from –200 cm/s to –11 cm/s is
added, for the forward movement from 11 cm/s to 100 cm/s, for the standstill range a
monitoring case from –10 cm/s to 10 cm/s is added.

3.8.4 Control input C on the S300 Professional, Professional CMS and Expert for
mobile applications

If, in a mobile application, the inputs A and B are connected to incremental encoders, then
the control input C can be used as an additional input for monitoring case switching.

On the S300 Expert, input C can also be selected for the application type Stationary. In this
operating mode all control inputs operate with static signals.

This input C uses complementary sampling and overwrites the incremental encoder inputs.

Input C

Connections

C1 C2

Logic Effect

1 0 0 Monitoring cases using incremental encoders

0 1 1 The monitoring case allocated to the input C is
activated.

0 0 Error Error

1 1 Error Error

3.8.5 Switching sequence

To check whether the monitoring cases are switched in the correct order during the
production process or over the route covered, you can configure a sequence for the
monitoring cases. Here you can define either an arbitrary sequence, a unique sequence, or
two alternative sequences.

Note

Fig. 6: Example: velocity
ranges

Note

Tab. 2: Action of the control
input C
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• Arbitrary sequence: It is allowed to switch from one monitoring case to any other
defined monitoring case.

• Unique sequence: It is only allowed to switch from a monitoring case to another
specifically defined monitoring case.

• Alternative sequence: It is allowed to switch from a monitoring case to one of two
specifically defined monitoring cases.

Use the monitoring of the monitoring case switching as an additional check on your
control. For example, in this way deviations from a sequence in the production process on
a system could be detected.

3.8.6 Allocating the field sets

You allocate a field set to each monitoring case. In the Field set list box you can select the
field sets you have already created. If the monitoring case is switched on, then the
configured protective field and the warning field for the related field set will be activated.

Next to the Field set list box you can see the OSSDs on which the selected field set acts. In
a master/slave system, the effect depends on the configuration of the output signal
switching devices.

3.8.7 Simultaneous field set of the S3000

On the S3000 safety laser scanner you can allocate a so-called simultaneous field set. If
you configure the S3000 with simultaneous field set, then the system monitors two field
sets simultaneously.

Effect of the field sets

Next to the list box for the field set or the simultaneous field set you can see the OSSDs on
which the selected field set acts. The action is dependent on the configuration of the
output signal switching devices.

• If the interruption of the protective field only switches the internal OSSDs, both field sets
act on these OSSDs (in the example on the front scanner (1)).

• If the interruption of the protective field only switches the external OSSDs on another
device (e.g. the OSSDs on a second S3000 or a series UE100 device), both field sets
act on the external OSSDs (in the example on the rear scanner (2)).

Recommendation

Fig. 7: Simultaneous field set
of the S3000

Fig. 8: Effect of the field sets
internally
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• If the interruption of the protective field switches both the internal and the external
OSSDs, the field set acts on the internal OSSDs (in the example on the front
scanner (3)), the simultaneous field set on the external OSSDs (in the example on the
rear scanner (4)).

3.8.8 Park mode

If, in mobile applications, vehicles are not moved for a time, the OSSDs and the laser on
the safety laser scanner can be switched off by the park mode. In this way the power
consumption of the device is reduced.

To switch to the park mode, configure a monitoring case and activate the mode using the
Park mode check box.

It is not possible to allocate a field set to the monitoring case.

As an alternative to the park mode, you can also use the stand-by mode (see also the
S300 operating instructions).

Fig. 9: Effect of the field sets
externally

Fig. 10: Effect of the field
sets internally and externally

Note
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3.8.9 Multiple sampling

With multiple sampling selected, an object must be detected several times in the same
beam before the safety laser scanner switches its OSSDs to the OFF state (see also the
operating instructions for the related safety laser scanner). In this way you can reduce the
probability that insects or particles result in the shutdown of the plant.

You can configure a specific multiple sampling for each monitoring case. In this way you
can, for instance, adjust vehicle monitoring to suit different ambient conditions.

On the safety laser scanner, a multiple sampling of 2 is the minimum setting. You can set
the multiple sampling to up to 16 with the aid of the CDS.

WARNING

For multiple sampling greater than 2, add the supplement to the basic response time!

Multiple sampling increases the response time (see also the operating instructions for the
related safety laser scanner). Under Resulting response time supplement you can see
the supplement that you must add to the basic response time.

Recommended multiple sampling Application

2 times Stationary under clean ambient conditions

2 … 4 times Mobile

4 … 8 times Stationary under dusty ambient conditions

3.9 Edit field sets of the safety laser scanner
You can edit the field set(s) for a safety laser scanner in a Field set editor. Depending on
the scanner used, the laser output aperture, the protective field and the warning field are
displayed with a 190° angle or a 270° angle.

190° on the S3000 270° on the S300 and S200

Tab. 3: Recommended
multiple sampling for
different applications

Fig. 11: Field set view is
dependent on the scanner
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In the Field set editor window you can edit the protective field and warning field for the
created field sets with the aid of various Tools (1).

The most important menu commands for editing the protective fields and warning fields
are also available as buttons on the toolbars (2) in the window.

To adapt the window to suit your needs, you can set view (3).

You can also use the contour of the protective field as a reference and monitor the
reference.

In the Field set editor window you can also display the contour of the surroundings as
scanned by the safety laser scanner.

You can open the Field set editor window using the Edit field sets... command on the
context menu for the related device symbol.

The maximum protective field ranges depend on the resolution configured for the safety
laser scanner. If you change the resolution later, it may not be possible to transfer
protective fields already drawn to the devices. The maximum protective field range is
displayed as a violet line (1) in the field set editor.

Fig. 12: Field set editor

Fig. 13: Display of the
maximum protective field
range in the field set editor

Note
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3.9.1 Symbols in the field set editor

You can hide or show all toolbars completely, or hide or show selected toolbars.

Print Show all Protective field or warning field
in the foreground

Undo Zoom in Edit protective field

Redo Zoom out Edit warning field

Cut Show no user-defined points Viewing the surrounding contour

Copy Show user-defined points Protective field suggestion

Paste Show all beams Select objects

Delete selected point Cartesian grid Edit freehand line

Polar grid Edit straight line

Edit sector of a circle

How to hide or show the toolbars:

� From the View menu, under Toolbars, select a toolbar. The selected toolbar is hidden or
shown.

3.9.2 Set view

To be able to work optimally with the field set editor, you can change the screen layout.

How to switch between cartesian and polar view:

� From the View menu select the Cartesian command. The grid lines are shown as a
cartesian grid.

Or:

� From the View menu select the Polar command. The grid lines are shown as a polar
grid.

Cartesian grid Polar grid

How to adjust the beam view for the protective field and warning field:

� From the View menu select the No points command. Neither user-defined points nor
beam end points of the safety laser scanner are shown for protective field and warning
field.

Fig. 14: Symbols in the field
set editor

Fig. 15: Field set display with
cartesian grid or polar grid
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Or:

� From the View menu select the User-defined points command. Only the user-defined
points are shown for protective field and warning field.

Or:

� From the View menu select the All points command. The user-defined points and all
beam end points of the safety laser scanner are shown for protective field and warning
field.

Display of no points or only of user-defined
points

Display of all points

How to change between protective field level and warning field level:

� From the Edit menu select the Select monitoring field command, Protective field. The
protective field of the safety laser scanner is shown (if already drawn) and can be edited
or re-drawn.

Or:

� From the Edit menu select the Select monitoring field command, Warning field. The
warning field of the safety laser scanner is shown (if already drawn) and can be edited
or re-drawn.

How to zoom in:

� Select the magnifying glass symbol with the plus sign.

� Click the area that you want to magnify. The view is enlarged.

Or:

� Select the magnifying glass tool with the plus sign and drag a selection rectangle to
select the section that you want to zoom. The section is enlarged to fill the window.

To change quickly to the Zoom out function, press and hold the [Ctrl] key. The
magnifying glass tool is changed.

How to zoom out:

� Select the magnifying glass symbol with the minus sign.

� Click the area that you want to scale down. The view is reduced.

To change quickly to the Zoom in function, press and hold the [Ctrl] key. The magnifying
glass tool is changed.

How to show the co-ordinates for the user-defined points:

� From the View menu select the Show coordinates command.

� From the View menu select the User-defined points command or the All points
command.

� Mark one or more points. The co-ordinates for the point marked/points marked are
displayed.

Fig. 16: Display of the field
contour

Note

Note
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3.9.3 Editing the protective fields and warning fields

You can edit a protective field or a warning field with the aid of Freehand lines, Straight
lines or with Sectors of a circle.

The maximum protective field range, which is dependent on the resolution, is indicated as
a violet line (1) in the field set editor.

Take into consideration that only objects with the resolution set can be safely detected. If
you draw narrow protective field segments, this aspect is no longer assured.

Exporting or copying protective fields and warning fields

You can export individual protective fields and warning fields and import them into other
field sets or other safety laser scanners.

• To export or import the protective field, switch to the protective field level using the
toolbar or using the menu, and export or import the field using the File menu.

• To export or import the warning field, switch to the warning field level using the toolbar
or using the menu, and export or import the field using the File menu.

You can copy and paste the points marked on a protective field or warning field. In this way
you can, for example, copy a protective field and paste it in another field set.

How to select the required field set:

� Select the required field set on the toolbar.

Or:

� From the Edit menu select the Select field set command, [Name of the field set].
You can now edit the field set.

Fig. 17: Co-ordinates of the
user-defined points

Note

Fig. 18: Display of the
maximum protective field
range in the field set editor

Note

Fig. 19: Choose field set to be
edited
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Depending on the settings in the options, the protective fields and warning fields for the
other field sets are displayed as dotted lines.

How to edit the protective field and warning field using the Freehand line tool:

� In the Field set editor window, on the Tools menu select the Freehand line command
or select the related symbol on the toolbar.

� Click any point on the desktop and drag the mouse pointer over the desktop. In this way
the protective field or warning field is created point by point on the screen.

Or:

� Click various points on the surface in succession. The points are automatically joined to
form a protective field or warning field.

Using the [Ctrl] key you can restrict the possible user-defined points to the horizontals
or verticals.

How to edit the protective field and warning field using the Straight line tool:

� In the Field set editor window, from the Tools menu select the Straight line command
or select the related symbol on the toolbar.

� Click the first (right) point of the protective field or warning field required (1).

� Then drag the protective field or warning field to the next corner point (2).

� Then position the next corner point by clicking with the mouse. The protective field or
warning field is automatically filled accordingly (3).

� Then drag the protective field or warning field to the next corner point.

� Continue positioning corner points until the protective field or warning field has the
required shape and size.

Using the [Ctrl] key you can restrict the possible user-defined points to the horizontals
or verticals.

Note

Fig. 20: How to edit the fields
using the Freehand line tool

Note

Fig. 21: How to edit the fields
using the Straight line tool

Note
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How to edit the protective field and warning field using the Sector of a circle tool:

� In the Field set editor window, from the Tools menu select the Sector of a circle
command or select the related symbol on the toolbar.

� Click the bottom right point of the required protective field or warning field (1).

� Then drag the protective field or warning field anticlockwise (2).

� Release the mouse button. The protective field or warning field is shown coloured (3).

Or:

� Keep the [Ctrl] key pressed.

� Click the bottom left point of the required protective field or warning field.

� Then drag the protective field or warning field clockwise.

� Release the mouse button. The protective field or warning field is shown coloured.

How to move user-defined points for a protective field or warning field:

� In the Field set editor window, on the Tools menu select the Select command or click
the related symbol on the toolbar.

� From the View menu select the User-defined points command. The user-defined points
for the protective field or warning field are shown as small squares.

� Click one of these squares. The user-defined point changes colour (1).

� Now drag it to the required position using the mouse (2).

When a point is moved you can see the co-ordinates of the mouse pointer in the status
bar. Use this information to move the point to the required position.

Move several user-defined points simultaneously:

� Drag a selection rectangle around the user-defined points that you want to move (1). All
user-defined points in the selection rectangle change colour (2).

Or:

� Click the first user-defined point. The colour changes.

Fig. 22: How to edit the fields
using the Sector of a circle
tool

Fig. 23: Move user-defined
points

Note
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� Keep the Shift key pressed.

� Click the next user-defined point. This also changes colour.

� Mark as many user-defined points as necessary with the shift key pressed.

� Then drag the protective field or warning field to the required position by dragging one
of the marked user-defined points.

Only move user-defined points radially:

� Keep the [Alt] key pressed. You can only move the user-defined points radially
towards or away from the laser scanner.

How to delete user-defined points for a protective field or warning field:

� In the Field set editor window, on the Tools menu select the Select command or click
the related symbol on the toolbar.

� From the View menu select the User-defined points command. The user-defined points
for the protective field or warning field are shown as small squares.

� Click one of these squares. The user-defined point changes colour.

Fig. 24: Move several user-
defined points
simultaneously (1)

Fig. 25: Move several user-
defined points
simultaneously (2)

Fig. 26: Delete user-defined
points (1)
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� From the Edit menu select the Delete command or click the corresponding symbol on
the toolbar. The user-defined point is deleted, the protective field or warning field takes
on a corresponding shape.

Delete several user-defined points simultaneously:

� Drag a selection rectangle around the user-defined points that you want to delete. All
user-defined points in the selection rectangle change colour.

Or:

� Click the first user-defined point. The colour changes.

� Keep the Shift key pressed.

� Click the next user-defined point. This also changes colour.

� Mark as many user-defined points as necessary with the shift key pressed.

� From the Edit menu select the Delete command or click the corresponding symbol on
the toolbar. The user-defined points are deleted, the protective field or warning field
takes on a corresponding shape.

How to undo an action:

� From the Edit menu select the Undo command or click the corresponding symbol on the
toolbar. The action performed last is undone.

Fig. 27: Delete user-defined
points (2)

Fig. 28: Delete user-defined
points (3)

Fig. 29: Delete several user-
defined points
simultaneously (1)

Fig. 30: Delete several user-
defined points
simultaneously (2)
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How to redo an action undone:

� From the Edit menu select the Redo command or click the corresponding symbol on the
toolbar. The action undone last is redone.

3.9.4 Protective field or warning field suggestion

The CDS can suggest a protective field or warning field. The safety laser scanner scans the
visible room contour several times. From the data obtained the CDS determines the
contour of the related field (see also the operating instructions of the related safety laser
scanner).

The measurement tolerances of the safety laser scanner are automatically subtracted
from the protective field suggested. As a result the protective field is slightly smaller than
the surface covered.

WARNING

Check the protective field suggested!

The protective field suggested is not a replacement for the calculation of the safety
distance. Calculate the safety distance based on the chapter “Mounting” and check the
protective fields, prior to commissioning the application, using the instructions in the
chapter “Commissioning” and using the “Checklist” in the operating instructions of the
related safety laser scanner.

You can edit the fields suggested in two ways:

• Move the individual points of the field using the mouse until the field is of the required
shape and size.

• Walk along the field boundary required and during this process hold up a so-called
target board (for example a piece of cardboard at least 10 × 10 cm) at the boundary
required for the protective field. During this process you can see how the protective field
suggested in the CDS changes.

How to have a protective field suggested:

� Switch to the protective field level in the field set editor using the toolbar.

� On the toolbar click the button shown below.

A warning will be displayed by the CDS that the actual protective field will be overwritten.

� Click the Yes button. The room contour is scanned and displayed.

� If necessary, you can edit the protective field suggested using the drawing tools in the
field set editor.

How to have a warning field suggested:

� Switch to the warning field level in the field set editor using the toolbar.

� On the toolbar click the button shown below.

Note
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A warning will be displayed by the CDS that the actual warning field will be overwritten.

� Click the Yes button. The room contour is scanned and displayed.

� If necessary, you can edit the warning field suggested using the drawing tools in the
field set editor.

3.9.5 Viewing the surrounding contour

You can display the contour of the surroundings in the field set editor. In this way you can
change the protective field and warning field to suit. You can also detect obstacles that
prevent detection (for example pillars) or that would result in the shutdown of the OSSDs
(hanging cables, etc.).

You can also continually update the display of the contour of the surroundings. In this way
you can see on the screen how the contour of the surroundings changes when you move
obstacles, for example.

Depending on the power of your PC or notebook, some CDS functions will become slower
or will be impaired by the continual updating of the surrounding contour.

How to display the surrounding contour:

� On the toolbar in the field set editor click the button shown below.

The surrounding contour is scanned and displayed as a blue line in the field set editor.

Or:

� Keep the [Ctrl] key pressed and on the toolbar in the field set editor click the button
shown below.

The surrounding contour is scanned, displayed as a blue line in the field set editor and
continually updated.

Note
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3.9.6 Using the contour as a reference

With the function Contour as reference, a contour segment is also applied to the
monitored area. This contour segment is added in the field set editor and its depth
adjusted (positive (2) and negative (1) tolerance band).

Within the tolerance band, the contour of an object (e.g. the floor) must cover the entire
width of the segment, i.e. an object must always be present (the contour is used as a
reference).

The OSSDs of the safety laser scanner change to the OFF state if …

• there is an object in the protective field.

• the room contour is no longer fully within the tolerance band, e.g. due a change in the
position of the safety laser scanner (protection against tampering).

You can set the size of the tolerance band in the field set editor options.

The depth of the negative tolerance band can be set such that it protrudes into the
protective field or starts directly at the boundary of the protective field.

• It is not possible to edit a warning field where there is a contour segment. Any existing
warning field will be deleted by adding the contour segment in this area.

• As many contour segments as required can be added.

How to create a contour segment:

� You can only create a contour segment if you have already prepared a protective field.
Thus first create the protective field for your application.

� From the Tools menu select the Create contour command. An angle symbol appears
next to the mouse pointer.

Fig. 31: Tolerance band for a
contour segment

Notes
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� Click the outermost point on the right of the contour segment (1).

� Then drag the mouse pointer to the outermost point on the left of the segment (2).

� Release the mouse button (3). The contour segment is created with a positive and
negative tolerance band (as set in the options).

How to reduce a contour segment:

� Go to the Tools menu and select the Reduce contour command. An angle symbol
appears next to the mouse pointer.

� Click the point from which you want to reduce the contour segment (1).

� Then drag the mouse pointer to the point to which you want to reduce the contour
segment (2).

� Release the mouse button (3). The contour segment is reduced appropriately. A warning
field is now in the place where there was previously a contour segment.

Fig. 32: Adding a contour
segment

Fig. 33: Reducing a contour
segment
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How to edit a contour segment:

Negative tolerance band

� Switch to the protective field level in the field set editor using the toolbar.

� Select one of the tools to edit the protective field (freehand line, straight line or sector of
a circle).
In the area of the contour segment you can now change the protective field and with it
the negative tolerance band.
However, you cannot increase the size of the protective field beyond the contour
segment. For this purpose you must first reduce the contour segment again.

Positive tolerance band

� Switch to the warning field level in the field set editor using the toolbar.

� Select one of the tools to edit the protective field (freehand line, straight line or sector of
a circle) and change the positive tolerance band with the tool.
During this process you can only reduce the contour field to the original protective field
boundary.

3.10 Options for editing the field set

3.10.1 Pre-setting of the view

In this dialog box you can set the direction in which the laser scanner’s scanning range is
to be aligned in the Field set editor window: Up (standard), Down, Left or Right.

Pointing down Pointing up

Pointing right Pointing left

Fig. 34: Alignment of the
scanning range in the field
set editor
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Under Representation of the monitoring areas choose whether all field sets are to be
shown in the Field set editor window or only the one currently selected:

• all created
Along with the field set currently selected, the protective fields and warning fields for all
other field sets created are displayed as dotted lines.

• only the currently selected
Only the protective field and the warning field for the field set currently selected are
displayed.

All created monitored areas Only the currently selected monitored area

3.10.2 Pre-setting of the grid

In this dialog box you enter the basic setting for the grid lines. When the Field set editor
window is opened, the grid is shown in the preset form.

You can choose between a cartesian grid and a polar grid. A cartesian grid is suitable for
rectangular field sets or polygon-shaped field sets, a polar grid is suitable for circular field
sets.

Cartesian grid Polar grid

3.10.3 Colour settings

In this dialog box you can enter the Colour of the grid.

Laser scanner, protective field, warning field and background have fixed colour definitions
that cannot be changed.

Fig. 35: Representation of
the monitored areas in the
field set editor

Fig. 36: Basic setting for the
grid view
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3.10.4 Pre-setting for the protective field

You can set the field editor such that on opening a new field set, a protective field is
already defined.

First choose whether the default is to be No protective field, a Rectangle or a Sector of a
circle.

� If you have selected Rectangle, on the Rectangle tab enter the Height, the Width and
the Distance to the laser scanner.

� If you have selected Sector of a circle, on the Sector of a circle tab enter the Radius.

You can only enter values within the size of the protective field on the scanner used and its
variants (see also the operating instructions of the related safety laser scanner).

Rectangle Sector of a circle

Resulting protective field Resulting protective field

Note

Fig. 37: Choosing a pre-
setting for the protective field
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3.10.5 Pre-setting for the warning field

First choose whether the default is to be No warning field, a Rectangle or a Sector of a
circle.

� If you have selected Rectangle, on the Rectangle tab enter the Height, the Width and
the Distance to the laser scanner.

� If you have selected Sector of a circle, on the Sector of a circle tab enter the Radius.

You can only enter values within the size of the warning field on the scanner used and its
variants (see also the operating instructions of the related safety laser scanner).

Rectangle Sector of a circle

Resulting warning field Resulting warning field

3.10.6 Pre-setting for the contour segments

Define a positive and a negative tolerance band for the contour segments that you add
using the field set editor. You can only enter values between 10 cm and the maximum
protective field range.

• The values entered relate to the boundary of the protective field:

– +15 cm/–15 cm = The tolerance band protrudes 15 cm beyond the protective field
and 15 cm into the protective field.

– +15 cm/–0 cm = The tolerance band starts at the boundary of the protective field
and protrudes 15 cm beyond the protective field.

• The tolerance bands must not be set to less than +10 cm/–0 cm.

Note

Fig. 38: Choosing a pre-
setting for the warning field

Notes
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4 Service

4.1 Optics cover/front screen calibration
The level of contamination is measured continuously during the operation of the safety
laser scanner. For this purpose the optics cover/front screen calibration must first be
performed; this then serves as a reference for the contamination measurement (status =
not contaminated).
The calibration is only allowed to be performed with a new optics cover or front screen! The
new optics cover or front screen must be free of contamination at the time of the
calibration. The optics cover calibration should be performed at room temperature
(1030 °C)!

WARNING

Only calibrate immediately after replacement with a brand-new, clean optics cover or
front screen!

If you perform the calibration with an optics cover or front screen that has already been
used or that is already contaminated, the laser scanner detection features will be
degraded.

How to perform a front screen calibration:

� On the context menu for the S3000/S300/S200 device symbol choose the command
Service, Optics cover calibration or Front screen calibration. A warning is displayed;
this warning informs you that you are only allowed to calibrate immediately after
replacement with a brand-new, clean optics cover or front screen.

� Only click the OK button if you have replaced the optics cover or front screen with a
brand-new, clean optics cover or front screen! The message Calibration has been
performed appears.

4.2 Restart of the safety laser scanner
Via the CDS you can restart the scanner. In this way the power-up process is simulated
with the aid of the software. For example, re-start the scanner if the safety laser scanner is
in the lockout operational status.

During restart the OSSDs will be switched to the OFF state.

How to restart the safety laser scanner:

� From the context menu for the device symbol select the command Service, Restart
scanner. The safety laser scanner performs the power up sequence (see also the
operating instructions of the related safety laser scanner, chapter “Commissioning”).

Note
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5 Data recorder
The data recorder enables you to display and record various operating data for the safety
laser scanner while online. With the aid of the data recorder you can, e.g. display the
scanner’s measured scan line and infringements of the protective field or warning field,
and observe the states of the control inputs (see also section 5.1 “User interface
elements” on page 38).

The data displayed can be recorded and saved in a file. It is often possible to localise and
identify errors during operation by recording operating data over a longer period in some
circumstances.

You can start or stop the recording automatically using configurable trigger conditions. For
example, the data recorder can be set-up such that it only records data on a protective
field infringement in a specific monitoring case. With the aid of the trigger conditions you
can localise and systematically track down errors in an application.

Fig. 39: Data recorder online
on an S3000 application
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5.1 User interface elements
The user interface for the data recorder comprises the following elements:

Display of the LEDs and the
7segment display

Activated monitoring case with
the field set assigned to it (with
the S3000 an field set that
may be allocated
simultaneously)

Velocity that is present at the
dynamic control inputs

Status of the control inputs

Date and time of a recording

Number for the current data
record and number of data
records

Slider for replay speed

Monitored area with:
protective field = red
warning field = yellow
retrieved room contour = blue

Tab. 4: Elements on the user
interface
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I/O traces with the velocities
present at the incremental
encoders or the levels present
at the control inputs

5.1.1 Changing the user interface

You can modify the user interface for the data recorder to suit your needs:

• show or hide status indications and toolbar

• show or hide monitoring areas and I/O traces

• rotate the view of monitoring area by 90° or 180°

• cartesian or polar display of the grid lines for the monitored area

Cartesian Polar

� Use the selections on the View menu to change the settings to suit the current session.

� On the Options menu, use the Settings dialog box to save these settings, i.e. for all
future settings.

In the Settings dialog box you can also save changes to other aspects of the way the
user interface is displayed:

– colour settings
– show or hide I/O data in the I/O data and I/O traces areas
– display of graphic elements, e.g. protective field or room contour

Fig. 40: Cartesian or polar
view

Note
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5.1.2 Detailed view

All the angular steps on the safety laser scanner are displayed individually in the data
recorder detail view. In particular, you can see at which angular steps there is/was an
object in the protective field.

The following data are displayed for each angular step:

• column Status: correct, object in protective or warning field

• column r-PF1: configured protective field radius

• column r-WF1: configured warning field radius

• column r-PF2: configured radius of any simultaneously present protective field (only
possible on the S3000)

• column r-WF2: configured radius of any simultaneously present warning field (only
possible on the S3000)

• column r-scan: radius of the scanned room contour

You can restrict the view of the beams on the View menu in the Detailed view window with
the aid of the Display only faulty beams command. Only the scanner beams that are
interrupted by an object in the protective field or warning field are displayed.

5.2 Usage of the data recorder

The data recorder is operated using a toolbar. The symbols are similar to the usual
symbols on a video recorder or tape recorder and also have so-called tooltips for
identification.

You can also run all functions using the Recorder menu.

Fig. 41: Individual angular
steps in the detail view

Note

Fig. 42: Toolbar for operating
the data recorder
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5.2.1 Display and record data

For it to be possible for the data recorder to display and also record data, you must first
connect the CDS and then the data recorder to the safety laser scanner.

� In the toolbar of the data recorder, click on the Connect button. The actual operating
mode is indicated on the safety laser scanner.

Recording data

� In the toolbar of the data recorder, click on the Start recording button.
A dialog box is opened in which you can enter the name and folder for the file where you
want to save the data.

You must also start the recording and add a file if you use trigger conditions, i.e. the
actual recording only starts later.

5.2.2 Playing back saved files

� Open a recorded file (file extension .REC).

The project opened in the CDS must match the project used during recording.

You can the start, stop or end replay using the buttons on the toolbar. In addition, you
can also move forward or back in steps or to the start or the end of the recording.

In addition, you can move forward or back directly in the recording by clicking the
I/O traces displayed.

Changing replay speed

The Rel. replay speed slider can be used to regulate the replay speed.

� Move the slider to the left to slow down the replay speed.

� Move the slider to the right to increase the replay speed.

Note

Note

Fig. 43: Navigation within the
recording with the aid of the
I/O traces

Fig. 44: Slider for regulating
the replay speed
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5.2.3 Setting the trigger conditions (simple mode)

With the aid of the trigger conditions (Options menu, Settings) you can define when the
data recorder is to record application data.

In the “simple mode” you activate one or more conditions and select AND or OR as the
operator between the conditions.

Example 1

You link the conditions OSSD has switched and Switching to monitoring case no. 2. with
AND. The data recorder records data as soon as both conditions are met. If the scanner
switches the OSSD back on or if the scanner is switched to a different monitoring case
using the control inputs, the recording is interrupted.

Example 2

You link the conditions Warning field has been infringed and Switching to monitored
area no. 3 with OR. The data recorder records data as soon as at least one of the two
conditions is met. Recording is only interrupted if neither of the two conditions continues
to be applicable.

Fig. 45: Dialog box for setting
the trigger conditions
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5.2.4 Setting the trigger conditions (expert mode)

With the aid of the trigger conditions, you can define when the data recorder is to record
application data.

� In the dialog box Settings in the Trigger conditions area, click on the Expert mode
button in order to switch into expert mode.

In the Boolean expression field you can either enter conditions directly or assemble them
using the Insert trigger condition and Paste operator list boxes.

Example:

You define as a condition PROT AND NOT MONCASE = 2. The data recorder records data
as soon as there is an object in the protective field, but the scanner is not in monitoring
case 2.

Fig. 46: Dialog box for setting
the trigger conditions in
expert mode
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Data recorder

Checking the trigger conditions

You can have the trigger conditions entered checked for plausibility. Click on the Check
expression button. The data recorder checks whether the conditions entered are plausible
(e.g. whether the monitoring cases entered are configured).

How to define a Boolean expression in the expert mode:

� If you want to exclude (invert) the trigger condition to be entered, then choose “NOT” in
the Paste operator list box.

The operator is inserted in the Boolean expression field at the cursor position.

� In the Insert trigger condition list box choose the required trigger condition.
The trigger condition is entered in the Boolean expression field at the cursor position.

� If you want to add further trigger conditions, then choose the required operator, e.g.
“AND” in the Paste operator list box.

� Repeat the previous steps until you have defined the required expression.

• You can assemble the Boolean expression either with the aid of the list boxes or enter it
manually. The entries are not case sensitive.

• A single condition inserted with the aid of the Insert trigger condition list box is always
a correct Boolean expression that yields the value True or False on the evaluation of the
logical value.

• Note that the data recorder handles Boolean operators with the usual priority during the
evaluation of the trigger condition.

• You can group the complete trigger condition by using round brackets and as a result
change the priority of the evaluation. Nested brackets are allowed.

Fig. 47: Indication of errors in
the trigger conditions

Notes
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6 Notes and warnings

6.1 No operating instructions available for the safety laser
scanner

Possible cause Rectification of the error

No operating instructions in the
Portable Document Format (PDF)
were found on your PC.

� Repeat the installation of the CDS.

Or:

� Open the operating instructions directly from
the installation CDROM.

Acrobat® Reader™ has not yet been
installed on your PC. To display the
operating instructions, Acrobat®

Reader™ must be installed on your
PC.

� Install Acrobat® Reader™ from the CDS
installation CD-ROM.

Or:

� Open the operating instructions directly from
the installation CDROM.

How to install Acrobat® Reader™ from the installation CD-ROM:

� Place the installation CDROM in your CDROM drive. After a few seconds the SICK
installation wizard starts automatically.

If Windows does not start the installation wizard automatically:

– Click Run... in the Start menu.
– Enter the following command line in the Open field:

[Drive letter for your CDROM drive]:\setup.exe
– Click on OK.

� In the Configuration & Diagnostic Software dialog box choose Acrobat Reader in the
Install software list box.

� Using the left mouse button click OK. The installation program for Acrobat® Reader™ is
loaded from CD-ROM.

� Follow the instructions in the Acrobat installation wizard.

Once the installation is complete, you will be able to open the operating instructions
directly from the CDS online help.

How to open the operating instructions directly from the installation CDROM:

� Place the installation CDROM in your CDROM drive. After a few seconds the SICK
installation wizard starts automatically.

If Windows does not start the installation wizard automatically:

– Click Run... in the Start menu.
– Enter the following command line in the Open field:

[Drive letter for your CDROM drive]:\setup.exe
– Click on OK.

� In the Configuration & Diagnostic Software dialog box, select the required document
from the Read documentation list box.

� Using the left mouse button click OK. Acrobat® Reader™ is loaded from the CD-ROM
and the required document is displayed on the screen. Neither Acrobat® Reader™ nor
the operating instructions are installed on your PC during this process.
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